DXGL 0.5.15 versions and requirements

Please read before posting.
Locked
William
Site Admin
Posts: 140
Joined: November 19th, 2011, 5:08 pm
Contact:

DXGL 0.5.15 versions and requirements

Post by William » July 13th, 2018, 11:07 am

As of DXGL 0.5.15, there will be a new "Modern" build available. Instead of building with Visual C++ 2010, it will be using Visual C++ 2017 Update 7 (or whatever update is available once released).

Please note this build will have the following system requirements:
SSE2 capable processor
Windows Vista SP2, Windows 7 SP1, Windows 8, Windows 8.1, or Windows 10

If you would like to try this build, you can download the latest source code from the SVN repository, and build it using Visual C++ 2017 (look for the VS2017 builds in the build dropdown).

Please note that VS2010 builds will continue to be available, however there is no guarantee they will build until closer to release as I now primarily develop DXGL on VS2017 in order to take advantage of all its features.

William
Site Admin
Posts: 140
Joined: November 19th, 2011, 5:08 pm
Contact:

New "Modern" builds coming soon

Post by William » July 13th, 2018, 9:55 pm

Revision 835 fully implements the new build mode, including all system requirements.

Please close the Visual Studio solution before updating to this revision, as this revision contains a change in certain project files.

William
Site Admin
Posts: 140
Joined: November 19th, 2011, 5:08 pm
Contact:

DXGL 0.5.15 versions and requirements

Post by William » September 18th, 2018, 8:25 pm

DXGL 0.5.15 is available in two versions:
The "standard" version is built using Visual C++ 2017 Update 8, and requires Windows Vista SP2, Windows 7 SP1, or higher and a SSE2-capable processor.
The "legacy" version is built using Visual C++ 2010 SP1 like previous versions, can run on any IA-32 processor, and requires Windows XP SP3 or higher.

Locked